PRF Financial Systems Maintenance

Incident Report for PRF

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 08:54 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2026 - 08:18 EDT

Identified

The financial system is currently unavailable. We have identified the issue and are implementing a fix.
Posted Mar 24, 2026 - 22:28 EDT
This incident affected: Enterprise Applications (Financial Systems).