Phone Outage

Incident Report for PRF

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 09:59 EST

Update

Phone services continue to be negatively impacted. Inbound and outbound calling is failing, and calls are unable to be transferred, and calls are not being sent to voicemail.

The provider has suffered a core infrastructure failure and are working to restore services.
Posted Feb 17, 2026 - 15:29 EST

Identified

The phone carrier is having network issues, resulting in inbound and outbound call failures.
Posted Feb 16, 2026 - 12:37 EST
This incident affected: Telephony (Phone Services).